Troubleshooting

The following section describes troubleshooting methods for issues encountered:
Scenario 1: Error message “404 Not Found” when trying to access the DataView login page.
404 Error
Root Cause
: The application root URL is invalid.
Solution
: Enter the valid application root URL.
Scenario 2: When generating a Chart with non-direct query by applying ranking with > 10000 as well as <10000, it displays a message such that "Please refer to the error log for more details." Or "All shards failed. Please refer to the error log for more details."
Please Note:
It is working fine with direct query.
Workaround:
If user encounters such error, they need to increase the bucket size in Elasticsearch as mentioned below:
  • Go to dataimpoter log file and find recent printed string
    “Caused by: TooManyBucketsException or TooManyBucketsException”
    NOTE:
    Please check for the space and it is case sensitive.
  • Then locate the "Caused by" string:
    Caused by: TooManyBucketsException[Trying to create too many buckets. Must be less than or equal to:
    [10000] but was [10001]
    . This limit can be set by changing the [search.max_buckets] cluster level setting.]
  • The number shown in bold may vary. Please try by increasing the max search bucket size to double (example 20000).
  • This should solve the problem, however, if the same error message persists and similar log message is captured in the log, then try again by increasing the max search bucket size.
The below is the query to set the buckets size. In this example, we have given 50000.
PUT _cluster/settings { "transient": { "search.max_buckets": 50000 } }
Elasticsearch
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